Jump to content

AD-Blocker detected, please disable your ad-blocker when surfing in makerando.com - There is no invasive Ad.

 

kaine

User
  • Content count

    2971
  • Joined

  • Last visited

  • Days Won

    370

Everything posted by kaine

  1. Da quel che vedo non dovrebbe esserci nulla di sbagliato in questa parte del codice. Altrimenti il problema che riscontri lo troveresti anche andando verso destra/incrementando il valore della variabile... Quindi o ci sta qualcosa che non va nella parte in cui gestisci i tasti, oppure è qualcosa che ha a che fare con il come l'MV gestisce alcuni eventi/comandi in parallelo, ergo il tuo codice è giusto ma è un problema dell'engine. Mi è successo in passato con rpg maker 2k3, che utilizzassi loop annidati e il tutto andasse in vacca durante i test, dopo giorni scopro gironzolando per la rete che il mio codice era giusto sin dal principio ma non funzionava per via di un bug dell'engine, fortunatamente nel mio caso esisteva una patch per il problema. Al momento non mi vengono altre ipotesi in mente. Edit: Dimenticavo potrebbe essere anche un problema di prestazioni, con l'MV hanno cambiato molte robe e cambiato anche il linguaggio di programmazione, attualmente richiede risorse in più rispetto alle versioni precedenti del tool.
  2. kaine

    RPGMAKER 2003 Sacred Hell (Reboot)

    Oggi ho fato la muta tipo i serpenti poco prima di entrare in doccia, per dare contesto, venerdi scorso mi sono ustionato la schiena stando senza maglietta sotto il sole rovente, quindi tra caldo e umidità la pelle vecchia che stava li li per iniziare a staccarsi, aderendo alla maglietta tramite il sudore ha fatto l'effetto ceretta/muta staccandosi e restando nella parte interna della magliatta 😂😂😂
  3. Qualche screen del codice e del menu in game aiuterebbe a capire meglio il funzionamento e la situazione visivamente parlando.
  4. Con mio sommo piacere vi informo che è stata rilasciata una patch che permette di utilizzare ben 96 glifi 😍 La patch è compatibile sia per rpgmaker 2000(v1.07-v1.51-v1.61-v1.62) che rpgmaker 2003(v1.08-v1.09-v1.11-v1.12) Autore: KotatsuAkira Link Download: https://www.mediafire.com/file/ee4fo9tvf9qksku/RPGMakerPatch_EXtraFONT.7z/file Cosa cambia oltre ad avere più glifi? Qui arriva la nota dolente(in parte) in quanto cambiano i codici da utilizzare per richiamarli ed il template per gli stessi(adesso formato da 24 glifi per riga invece di 13). Comunque in caso di dubbi, all'interno dell'archivio oltre alle varie versioni della patch per i tool supportati, troverete la tabella dei codici da utilizzare per richiamare i glifi(EXtraFONT_CharTable.TXT) ed il template (EXtraFONT_Sample.BMP). Prima di Applicare la patch dovrete modificare il file rpg_rt.exe tramite resource hacker per sostituirne i glifi. Dopodiché non vi resta che applicare la patch con questo programmino qui: https://www.mediafire.com/file/5jf9r44itbm7674/lips102.zip/file Nel caso in cui invece avete patchato il vostro gioco con la versione 0.20 di Dynrpg mettete la patch direttamente nella cartella DynPatches, senza dover patchare l'exe.
  5. kaine

    RPGMAKER 2003 EXtraFONT

    No, credo siano file che aggiunge in automatico Internet Archive, il sito dove sono state caricate le patch. Quel che serve è unicamente il file .ips ed ovviamente l'immagine dei glifi in questo determinato caso
  6. Questa patch è solo per la versione ufficiale di rpgmaker 2003(1.12a) Autore: BingShan Link Download: Patch: https://ux.getuploader.com/xingqier/download/194 TPC: https://ux.getuploader.com/xingqier/download/193 Qui trovate il nuovo sito con le varie informazioni aggiornate sulla patch(vi consiglio altamente l'uso di google translate in inglese se volete capirci qualcosa, non in italiano perché google è pessimo con la nostra lingua): https://bingshan1024.github.io/steam2003_maniacs/ Qui trovate l'elenco delle funzionalità che apporta questa patch tradotte in inglese(tramite google translate): Comandi Modificati: Nuovi comandi Installazione della patch: Nota: Prima di procedere fate una copia di backup della cartella in cui tenete rpgmaker per precauzione, non sia mai che qualcosa vada storto! Una volta che avete estratto l'archivio avviate utility.exe Selezionate il metodo di aggiornamento degli eventi della mappa(l'ultimo da quanto vedo è incompatibile al momento) Immediately(Default) Nella nuova versione dovrebbe essere selezionato in automatico ed in lingua inglese. Selezionate la cartella in cui si trova il tool Source Folder(io per sicurezza ho usato una copia della cartella che tenevo sul desktop) Dopodiché selezionate la cartella di destinazione Destination Folder Una volta selezionati i due percorsi cliccate sul pulsantone immediatamente sotto Apply Patch Quando vi verrà chiesto il permesso per avviare patch.exe date l'ok Se l'applicazione della patch è andata a buon fine vi apparirà un piccolo box con una piccola scritta incomprensibile.(Se il messaggio dovesse essere differente chiudete e ripetete l'operazione) Premete su OK. In automatico vi si aprirà la cartella in cui avete deciso di inserire il tool con la patch applicata. Adesso potete chiudere utility.exe La parte sul fondo in cui si vedono dei progetti, serve solamente nel caso in cui dobbiate convertire un progetto già in corso nella versione ufficiale del tool. Se dovete creare un nuovo progetto non vi serve.
  7. kaine

    RPGMAKER 2003 EXtraFONT

    Solo la prima, il secondo IPS serve solo a rimuovere la patch nel caso in cui la applichi manualmente con Lunar IPS, ma con Dynrpg tu non applichi realmente la patch nell'exe, ti limiti ad iniettarla all'avvio, credo che mettendole insieme i risultati possibili sono 2: 1)Le due patch si annullano a vicenda e l'exe vedendo un file per i glifi sballato nelle dimensioni crasha 2)Esplode tutto con il rischio di corrompere il tutto 😂
  8. kaine

    RPGMAKER 2003 Maniacs Patch

    Scoperto l'arcano! Ci stava da aggiornare anche l' rpg_rt.exe, io nel progetto stavo utilizzando quello dell'ultima release ufficiale, una volta messa l'ultima versione in betatest presente su discord, i nuovi comandi funzionano mostrando tranquillamente la descrizione dell'item.
  9. Questa patch rimuove il processo di chiamata del menu principale predefinito tramite il pulsante di cancellazione (ad esempio ESC) e attiva invece uno switch (predefinito: #1017). Lo switch viene attivato solo se il menu è abilitato e tutti i controlli di sicurezza se il menu può essere chiamato in questo momento sono stati positivi. Questo assicura che i giocatori non possano rompere il tuo gioco saltando o distruggendo gli event-triggers sulla mappa corrente per sbaglio quando ci passano sopra/sopra nello stesso momento, un problema che è molto comune con i menu personalizzati fatti in RPG2000/2003. Il menu di default rimane disponibile tramite evento-comando. La patch è compatibile sia per rpgmaker 2000(v1.07-v1.50-v1.51--v1.60-v1.61-v1.62) che rpgmaker 2003(v1.00-v1.03-v1.05-v1.08-v1.09-v1.11-v1.12) Autore: KotatsuAkira Link Download: https://www.mediafire.com/file/wnjxmpy89ithjo8/RPGMakerPatch_SwitchOnMenuCall.7z/file Per applicarla dovete usare questo programmino qui: https://www.mediafire.com/file/5jf9r44itbm7674/lips102.zip/file Nel caso in cui invece avete patchato il vostro gioco con la versione 0.20 di Dynrpg mettete la patch direttamente nella cartella DynPatches, senza dover patchare l'exe.
  10. kaine

    RPGMAKER 2003 Map in Menu Patch

    Patch Aggiornata aggiunte nuove versioni compatibili!
  11. Questa patch permette di visualizzare una parte della mappa quando si entra nel menu Se la usate insieme a questo plugin: http://www.makerando.com/topic/279-system-transpwin/ potrete vedere tutta la mappa: Esempio: Autore: Cherry,KotatsuAkira(Porting rpg2000 v1.62 - rpg2003 v1.09) Link Download: 2000 v1.07 - 2003 v1.08 http://www.mediafire.com/download/b33wy32gs9cq6mu/MapInMenu.rar 2000 v1.62 - 2003 v1.09 https://www.mediafire.com/file/derii4bjto5vwgy/RPGMakerPatch_MapInMenu.7z/file Per applicarla dovete usare questo programmino qui: http://www.mediafire...674/lips102.zip Nel caso in cui invece avete patchato il vostro gioco con la versione 0.20 di dynrpg mettete la patch direttamente nella cartella dynpatches. enjoy ^^
  12. kaine

    RPGMAKER 2000 VarTimerPos

    Patch aggiornata aggiunto il supporto ad rpgmaker 2003 ed a varie versioni della maniacs patch, che stavolta hanno avuto una versione apposita per via del fatto che alcuni elementi utilizzati da questa patch sono trattati diversamente da Maniacs
  13. Tramite questa patch è possibile modificare la posizione del timer sia durante il gioco che in battaglia, alcuni esempi di utilizzo sono il cambiare angolo o far si che in determinate circostanze lo si possa shakerare, posizionare sopra un nemico o far si che segua costantemente l'eroe, un veicolo ecc ecc sta tutto alla vostra immaginazione. La patch è compatibile con Rpg Maker 2000 v1.62 - Rpg Maker 2003 v1.08-v1.09-v1.12 Rpg Maker 2003+Maniacs Patch mp210414_EN_IM-mp210414_EN_PF-mp210414_JP_IM-mp210414_JP_PF La patch utilizza le seguenti variabili: Timer 1 3401 - 3402 contengono i valori delle coordinate X e Y del timer in game 3403 - 3404 contengono i valori delle coordinate X e Y del timer in battaglia Solo 2003 : Timer 2 3405 - 3406 contengono i valori delle coordinate X e Y del timer in game 3407 - 3408 contengono i valori delle coordinate X e Y del timer in battaglia Autore: KotatsuAkira Link Download: https://www.mediafire.com/file/wv677ddsjv9dpv4/RPGMakerPatch_VarTimerPos.7z/file Nel caso in cui utilizziate la patch Screen32 all'interno dell'archivio è presente una versione compatibile con essa che andrà applicata solamente dopo aver applicato la prima. Per applicarla dovete usare questo programmino qui: https://www.mediafire.com/file/5jf9r44itbm7674/lips102.zip/file
  14. Patch aggiornata aggiunto il supporto a rpg maker 2000 v1.62 ed alla v1.08 di rpgmaker 2k3
  15. Questa patch consente di rendere la schermata di uscita dal gioco del menu predefinito più simile a quella di RPG Maker XP, VX e Ace, ovvero aggiunge un'opzione "Shutdown" tra "Yes"/"To Title" e "No"/"Cancel" che chiude l'applicazione di gioco. Il testo utilizzato per il comando "Shutdown" è lo stesso di quello utilizzato per "Shutdown" sulla schermata del titolo. Se volete andare fino in fondo, potete applicare anche la versione "MES" della patch RemoveQuitQuestion. Questa rimuove la finestra delle domande e cambia la fonte del testo di "Shutdown" nella stringa che normalmente verrebbe usata per la domanda ormai inutilizzata. Se invece si vuole solo rimuovere la finestra delle domande e mantenere la scelta sì-no, basta scegliere la versione "Classic" di RQQ. La patch è compatibile con rpg2000 v1.62 - rpg2003 v1.08-v1.09-v1.12 Autore: KotatsuAkira Link Download: https://www.mediafire.com/file/k5wuene7cmgquz3/RPGMakerPatch_ModernEndScreen.7z/file Per applicarla dovete usare questo programmino qui: http://www.mediafire...674/lips102.zip
  16. kaine

    RPGMAKER 2003 Direct item menu

    Patch aggiornata aggiunte nuove versioni compatibili
  17. Con questa patch quando andrete ad aprire il menu vi apparirà solamente la pagina degli oggetti. La patch è compatibile con rpgmaker 2000 v1.07-v1.10-v1.62 e rpgmaker 2003 1.05-v1.08-1.12 Autore: Cherry/KotatsuAkira(porting per rpg maker 2003 1.12) Link Download: (2000 v1.07 - 2003 v1.08) http://www.mediafire.com/download/tb5boxf6y35uw67/DirectItemMenu.rar (2000 v1.10-v1.62 - 2003 v1.05-1.12) https://www.mediafire.com/file/wxlssmhsv7idvrn/RPGMakerPatch_DirectItemMenu.7z/file Per applicarla dovete usare questo programmino qui: http://www.mediafire.com/download/5jf9r44itbm7674/lips102.zip Nel caso in cui invece avete patchato il vostro gioco con la versione 0.20 di dynrpg mettete la patch direttamente nella cartella dynpatches. Nota: questa patch può essere utilizzata pure su rpgmaker 2000.
  18. kaine

    RPGMAKER 2003 ColorShopper

    Patch aggiornata aggiunte nuove versioni compatibili
  19. ColorShopper impedisce che i personaggi del party vengano visualizzati in grigio quando non possono usare o equipaggiare un oggetto nel menu predefinito del negozio. La patch è compatibile sia per rpgmaker 2000(v1.07-v1.10-v1.50-v1.51-v1.52-v1.60-v1.62) che rpgmaker 2003(v1.03-v1.05-v1.08-v1.09-v1.12) Autore: Bugmenot, KotatsuAkira(porting rpg 2000 v1.07-v1.10-v1.50-v1.51-v1.52, rpg 2003 v1.03-v1.05-v1.08v1.09-v1.12) Link Download: 2003 v1.08 https://www.mediafire.com/file/5mgeu84voxjr14d/ColorShopper_-_RPG_RT2k3_v1.08.rar/file 2000 v1.07-v1.10-v1.50-v1.51-1.52-v1.60-v1.62 / 2003 v1.03-v1.05-v1.08-v1.09-v1.12 https://www.mediafire.com/file/c2qvy13aasye40d/RPGMakerPatch_ColorShopper.7z/file Per applicarla dovete usare questo programmino qui: http://www.mediafire...674/lips102.zip Nel caso in cui invece avete patchato il vostro gioco con la versione 0.20 di dynrpg mettete la patch direttamente nella cartella dynpatches.
  20. kaine

    RPGMAKER 2003 Maniacs Patch

    Non mi da nessun errore, ho scaricato quella postata il 25 marzo nel canale exe, dopo quella non ci stanno altri aggiornamenti postati, se non si conta un aggiornamento del tool versione jp del 27 marzo. 🤷‍♂️
  21. kaine

    RPGMAKER 2003 Maniacs Patch

    Ho scaricato il nuovo TPC e sostituito il tutto, sosvrascrivendo i file vecchi con quelli presenti nell'archivio, nonostante questo il comando per assegnare la descrizione alla variabile stringa non mi funziona proprio, mi son perso qualche passaggio? Teoricamente dovrebbe mostrarmi(vedi immagini sotto spoiler) la descrizione dell'item 1 seguita da ss, ma non prendendo la parte riguardante la descrizione ottengo solo il nome ed ss nella riga successiva
  22. kaine

    RPGMAKER 2003 Maniacs Patch

    Buono a sapersi io credevo che TCP fosse legato alla versione di Maniacs, invece è una roba a se stante sotto quel punto di vista, ho notato le varie build su Discord, ma non le ho mai scaricate per quel motivo. 😂 Per quanto riguarda i nuovi comandi ci sta una lista aggiornata? Edit: Trovata stava in メモ
  23. kaine

    RPGMAKER 2003 SwitchOnMenuCall

    Patch aggiornata! Chiunque utilizzi la versione precedente la sostituisca con la nuova a quanto pare ci stava un problema, che poteva portare alla corruzione/cancellazione di dati se non si inizializzavano non so quante switch in memoria all'avvio. Oltre alla risoluzione del problema son state aggiunte altre versioni supportate. 2000 v1.60 2003 v1.00-v1.03-v1.05(manco sapevo girassero per la rete versioni precedenti alla v1.08 del 2003)
  24. Questa patch elimina l'avvio della battaglia che normalmente avviene quando si verifica un incontro casuale. Lo Switch #1018 viene attivato al suo posto, e anche l'ID del gruppo di nemici che sarebbe stato scelto in battaglia dal sistema di gioco dalla mappa o dall'area viene memorizzato nella variabile #3355. La versione "MEPR", disponibile nell'archivio, aggiunge un aggiornamento forzato delle pagine degli eventi della mappa. Questo è necessario solo se si vuole catturare lo switch e/o la variabile usando le condizioni di evento-pagina. Le condizioni degli Eventi Comuni possono ancora catturare lo switch senza di essa (e il codice evento può sempre controllato da entrambi senza problemi). La patch è compatibile con rpg 2000 v1.62 che rpg2003 v1.08-v1.09-v1.12 Autore: KotatsuAkira Link Download: https://www.mediafire.com/file/0yq3dzmrj6dq84w/RPGMakerPatch_ERA.7z/file Per applicarla dovete usare questo programmino qui: http://www.mediafire...674/lips102.zip Nel caso in cui invece avete patchato il vostro gioco con la versione 0.20 di dynrpg mettete la patch direttamente nella cartella dynpatches.
  25. kaine

    RPGMAKER 2003 Direct item menu

    Aggiunto il porting per rpgmaker 2000 v1.62
×